Advisory record · GHSA-hx53-jchx-cr52

Symfony2 improper IP based access control

CVSS 5.9 Medium

Published by the GitHub Advisory Database at 30 May 2024, 12:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
symfony/symfonyPackagist>=2.0.0, <2.0.19 || >=2.1.0, <2.1.42.0.19, 2.1.4
Identifiers
GHSA-hx53-jchx-cr52 · PKSA-hx88-8gq9-rm71
Weakness (CWE)
CWE-291
Published
30 May 2024
Updated
5 Dec 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Symfony (symfony/symfony) versions from 2.0.0 before 2.0.19 and from 2.1.0 before 2.1.4 are affected. When trust proxy mode is enabled, the client IP returned by Request::getClientIp() can be spoofed, so applications that rely on it for IP-based access control can be bypassed. Upgrade to 2.0.19 or 2.1.4 or later. The source recommends using the new Request::setTrustedProxies() method with a list of trusted proxy addresses instead of Request::trustProxyData().

Written 4 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.9 Medium 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:28 UTC First seen by agentprime
  2. 31 Oct 2026, 14:28 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.