Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
pgAdmin 4 versions before 9.15 are vulnerable to symbolic-link path traversal in the File Manager. An authenticated user can create a symbolic link inside their own storage directory that points outside it, causing pgAdmin to write files to any path the pgAdmin process can reach. Upgrade pgAdmin 4 to version 9.15 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.2 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (PostgreSQL) |
- CISA KEV Not listed.
- EPSS 0.0032, the 25th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV