Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Versions of github.com/docker/distribution before 2.8.2-beta.1 are vulnerable to denial of service through the /v2/_catalog API endpoint. A remote attacker can send a request with an extremely large value for the record-count parameter, causing the server to allocate a very large slice and run out of memory, particularly on memory-restricted systems. Upgrade to 2.8.2-beta.1 or later; the source lists no workaround other than restricting access to the endpoint.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0094, the 61st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:15 UTC First seen by agentprime
- 31 Oct 2026, 14:15 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-hqxw-f8mx-cpmw
- OSV: GHSA-hqxw-f8mx-cpmw
- github.com/distribution/distribution/security/advisories/GHSA-hqxw-f8mx-cpmw
- nvd.nist.gov/vuln/detail/CVE-2023-2253
- github.com/distribution/distribution/commit/f55a6552b006a381d9167e328808565dd2bf77dc
- bugzilla.redhat.com/show_bug.cgi?id=2189886
- github.com/distribution/distribution
- lists.debian.org/debian-lts-announce/2023/06/msg00035.html