Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Snipe-IT (Packagist package snipe/snipe-it) versions before 8.4.1 are affected. An authenticated user who holds only the users.edit permission can send a request to the users API that sets the admin permission on their own account, because the API strips only the superuser key from the submitted permissions. This gives them admin privileges. Upgrade to version 8.4.1, which contains the fix; the source lists no workaround.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0032, the 24th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:58 UTC First seen by agentprime
- 31 Oct 2026, 13:58 UTC Confirmed by OSV