Advisory record · GHSA-hpv8-x276-m59f

vLLM Vulnerable to Remote DoS via Special-Token Placeholders

CVSS 6.5 MediumEPSS 0.0041 · 35th percentile

Published by the GitHub Advisory Database at 5 May 2026, 22:21 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
vllmPyPI>=0.6.1, <0.20.00.20.0
Identifiers
GHSA-hpv8-x276-m59f · CVE-2026-44222 · PYSEC-2026-3409
Weakness (CWE)
CWE-129
Published
5 May 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

vLLM versions from 0.6.1 before 0.20.0 are affected. An unauthenticated remote attacker can send a text-only prompt containing image or video placeholder tokens with no matching multimodal data, which triggers an unhandled IndexError during input-position computation. This can crash the worker or degrade availability. Upgrade vLLM to 0.20.0 or later; the source lists no other workaround.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.5 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0041, the 35th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:11 UTC First seen by agentprime
  2. 31 Oct 2026, 14:11 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.