Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Jetty's jetty-http package, versions 9.0.0 up to 9.4.52, 10.0.0 up to 10.0.16, 11.0.0 up to 11.0.16, and 12.0.0 up to 12.0.1, accepts a '+' character before the Content-Length value, which is more permissive than the RFC allows. The source gives few details on exploitation and states there is no known exploit scenario, though it notes request smuggling could be possible when Jetty sits in front of a server that does not close the connection after a 400 response. Upgrade to 9.4.52, 10.0.16, 11.0.16, or 12.0.1; no workaround is listed.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.013, the 70th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:18 UTC First seen by agentprime
- 31 Oct 2026, 14:18 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-hmr7-m48g-48f6
- OSV: GHSA-hmr7-m48g-48f6
- github.com/eclipse/jetty.project/security/advisories/GHSA-hmr7-m48g-48f6
- nvd.nist.gov/vuln/detail/CVE-2023-40167
- github.com/eclipse/jetty.project
- lists.debian.org/debian-lts-announce/2023/09/msg00039.html
- www.debian.org/security/2023/dsa-5507
- www.rfc-editor.org/rfc/rfc9110#section-8.6