Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
LiteLLM versions from 1.65.5 up to but not including 1.85.0 are vulnerable to reflected cross-site scripting through the /sso/debug/callback endpoint, which places identity-provider-supplied fields into an inline script block without HTML-safe escaping. An attacker who controls an account on the configured identity provider could craft a callback URL and get a logged-in proxy admin to open it, running script in the proxy's origin and potentially reading session cookies for admin access. The fix is to upgrade to LiteLLM 1.85.0.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.8 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-hhww-mrg2-969h
- OSV: GHSA-hhww-mrg2-969h
- github.com/BerriAI/litellm/security/advisories/GHSA-hhww-mrg2-969h
- github.com/BerriAI/litellm/pull/27498
- github.com/BerriAI/litellm/commit/13a193367f0ae2e7e8b29913e0d23a32d3bb0457
- github.com/BerriAI/litellm
- github.com/BerriAI/litellm/releases/tag/v1.85.0