Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Camel's camel-langchain4j-tools, camel-langchain4j-agent and camel-spring-ai-tools packages are affected in versions 4.8.0 through 4.18.2 and 4.19.0 through 4.20.0. The source gives few details on how the flaw is triggered, beyond that tool argument headers are not filtered against declared parameters. Users should upgrade to 4.18.3, 4.21.0, or a later release.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.3 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0069, the 53rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-hh8r-75r6-qrg9
- OSV: GHSA-hh8r-75r6-qrg9
- nvd.nist.gov/vuln/detail/CVE-2026-49042
- github.com/apache/camel/pull/23535
- github.com/apache/camel/pull/23551
- github.com/apache/camel/commit/5d0028f6bc7a70556dc1d408b1b6cadb59e1842d
- github.com/apache/camel/commit/6851a94075b82375381a7236e081292b67f6bf9a
- github.com/apache/camel/commit/e9c4541a91ce75ce4817d499e704299c3933edaa
- camel.apache.org/security/CVE-2026-49042.html
- github.com/apache/camel
- github.com/apache/camel/releases/tag/camel-4.18.3
- github.com/apache/camel/releases/tag/camel-4.21.0
- issues.apache.org/jira/browse/CAMEL-23621
- www.openwall.com/lists/oss-security/2026/07/06/17