Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's netty-codec-http package, versions 4.1.83.Final through before 4.1.86.Final, does not validate header values passed to DefaultHttpHeaders.set as an iterator of values. An attacker who can supply those header values can perform HTTP response splitting. Upgrade to netty-codec-http 4.1.86.Final or later. As a workaround, replace set calls that take an iterator with a remove call followed by add calls in a loop over the values.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0095, the 61st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:09 UTC First seen by agentprime
- 31 Oct 2026, 15:09 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-hh82-3pmq-7frp
- OSV: GHSA-hh82-3pmq-7frp
- github.com/netty/netty/security/advisories/GHSA-hh82-3pmq-7frp
- nvd.nist.gov/vuln/detail/CVE-2022-41915
- github.com/netty/netty/issues/13084
- github.com/netty/netty/pull/12760
- github.com/netty/netty/commit/c37c637f096e7be3dffd36edee3455c8e90cb1b0
- github.com/netty/netty/commit/fe18adff1c2b333acb135ab779a3b9ba3295a1c4
- github.com/netty/netty
- lists.debian.org/debian-lts-announce/2023/01/msg00008.html
- security.netapp.com/advisory/ntap-20230113-0004
- www.debian.org/security/2023/dsa-5316