Advisory record · GHSA-hff9-5pqw-6w9f

imgproxy has integer overflow in imgproxy ICO loader that causes denial of service and may permit remote code execution

CVSS 9.8 CriticalCritical

Critical, because:

  • CVSS score 9.8: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 30 Oct 2026, 22:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/imgproxy/imgproxy/v3Go>=4.0.0, <4.0.164.0.16
github.com/imgproxy/imgproxy/v2Go>=4.0.0, <4.0.164.0.16
github.com/imgproxy/imgproxyGo>=4.0.0, <4.0.164.0.16
Identifiers
GHSA-hff9-5pqw-6w9f · GO-2026-6897
Weakness (CWE)
CWE-122 · CWE-190
Published
30 Oct 2026
Updated
5 Nov 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

GHSA-hff9-5pqw-6w9f: imgproxy versions >=4.0.0 and <4.0.16 are affected through an integer overflow in the ICO image loader. A remote client who sends a crafted ICO image can trigger a heap overflow, which can crash the imgproxy process or potentially lead to remote code execution. Upgrade to version 4.0.16, which is the listed fix.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.8 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:11 UTC First seen by agentprime
  2. 31 Oct 2026, 14:11 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.