Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache HttpComponents Core httpcore5 versions before 5.4.3 and from 5.5-alpha1 before 5.5-beta2 are vulnerable. A remote attacker can send HTTP/1.1 messages with an excessive number of headers or excessively long headers, exhausting memory and causing a denial of service. Upgrade to 5.4.3 or 5.5-beta2.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0078, the 56th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-hf6x-8p5f-cgmf
- OSV: GHSA-hf6x-8p5f-cgmf
- nvd.nist.gov/vuln/detail/CVE-2026-54399
- github.com/apache/httpcomponents-core/commit/d96a00fec9b2e19f8005e35681df5f6cd6e21a9e
- github.com/apache/httpcomponents-core/commit/fdc53a32fe0fccf098cc67e71cd125e447c759ed
- github.com/apache/httpcomponents-core
- lists.apache.org/thread/zmxh1pl2zohov5ntdh4lt85gfrlchgpy
- www.openwall.com/lists/oss-security/2026/07/01/4