Advisory record · GHSA-h92m-42h4-82f6

postfix-mta-sts-resolver Algorithm Downgrade vulnerability

CVSS 6.9 MediumEPSS 0.0086 · 58th percentile

Published by the GitHub Advisory Database at 5 Jul 2019, 21:06 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
postfix-mta-sts-resolverPyPI<0.5.10.5.1
Identifiers
GHSA-h92m-42h4-82f6 · CVE-2019-16791 · PYSEC-2020-174
Weakness (CWE)
CWE-757
Published
5 Jul 2019
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The postfix-mta-sts-resolver package, versions before 0.5.1, can return an incorrect response from its daemon under rare conditions, which downgrades the effective MTA-STS policy. The source gives few details on the exact trigger or what an attacker must do to exploit it. Upgrade to version 0.5.1, which contains the fix; the advisory's linked patches for older versions are an alternative for users who cannot upgrade.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.9 Medium 3.1 CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0086, the 58th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:38 UTC First seen by agentprime
  2. 31 Oct 2026, 14:38 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.