Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Echo v4 (github.com/labstack/echo/v4) versions 4.0.0 through 4.16.0 are vulnerable because the opt-in Decompress middleware does not limit the expanded size of gzip-encoded request bodies. An attacker who can send requests to an affected route can send a small compressed body that expands to a very large one, causing excessive memory or CPU use and possible denial of service. Upgrade to v4.16.1, which adds a MaxDecompressedSize setting defaulting to 100 MiB. Alternatively, disable gzip request decompression on exposed routes or place BodyLimit after Decompress.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0037, the 31st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 28 Oct 2026, 19:17 UTC Confirmed by NVD
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-h7wr-284f-5qvc
- OSV: GHSA-h7wr-284f-5qvc
- github.com/labstack/echo/security/advisories/GHSA-h7wr-284f-5qvc
- github.com/labstack/echo/pull/3136
- github.com/labstack/echo/commit/3fb0ba7e17645bb65611e2a08875d0a2f65c421f
- github.com/labstack/echo
- github.com/labstack/echo/releases/tag/v4.16.1