Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Next.js versions from 16.3.0 before 16.3.8 are affected when Cache Components is enabled and a 'use cache' function calls another 'use cache' function that reads a root param. The enclosing function's cache key can omit that root param, so one cached entry may be served for different root param values, and downstream caches may spread it further. An attacker cannot choose which values leak, and the source does not say what network access or account is needed. Upgrade next to version 16.3.8, which is the fixed release; the source lists no workarounds.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.3 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-h694-7cp9-m8p3
- OSV: GHSA-h694-7cp9-m8p3
- github.com/vercel/next.js/security/advisories/GHSA-h694-7cp9-m8p3
- nvd.nist.gov/vuln/detail/CVE-2026-103004
- github.com/vercel/next.js/commit/e92db4536a7f34ae2dbda583cfa1b4e0d06d1865
- github.com/vercel/next.js
- github.com/vercel/next.js/releases/tag/v16.3.8