Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Poweradmin versions 4.0.0 up to 4.2.5 and 4.3.0 up to 4.3.4 are affected. A user holding the user_edit_others permission, but not superuser status, can use the REST API user-update endpoint to change the password of the administrator account and then log in as that administrator, giving full control. Upgrade to 4.2.5 or 4.3.4. The source gives no workaround besides upgrading, and it notes that the attack requires the API to be enabled and a delegated user-manager role to exist.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.8 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-h4hf-v6w5-897x
- OSV: GHSA-h4hf-v6w5-897x
- github.com/poweradmin/poweradmin/security/advisories/GHSA-h4hf-v6w5-897x
- github.com/poweradmin/poweradmin/commit/36e9081a5c83cb962dc6275b7adcd6cb463f1028
- github.com/poweradmin/poweradmin/commit/9bdda77bc103f283a0babcaf3355f3f95b360122
- github.com/poweradmin/poweradmin/commit/b90fd83e67e6d7b6ad6c9be3a1c0d2f45bd73b6c
- github.com/poweradmin/poweradmin/commit/ffb95d5201cad5cb38e3eabc4f8103cac2ca18e2
- github.com/poweradmin/poweradmin
- github.com/poweradmin/poweradmin/releases/tag/v4.2.5
- github.com/poweradmin/poweradmin/releases/tag/v4.3.4