Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The protobuf-java package (core and lite runtimes, along with protobuf-kotlin and protobuf-kotlin-lite) is affected in versions from 3.16.3 up to but not including 3.21.7, and in various other version ranges. An attacker who can supply binary or text-format input containing many repeated non-repeated embedded messages with repeated or unknown fields can cause long garbage collection pauses, leading to denial of service. Upgrade to 3.21.7, 3.20.3, 3.19.6, or 3.16.3, matching your release line.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.3 | Medium | 3.1 | CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | CNA (Google) |
- CISA KEV Not listed.
- EPSS 0.013, the 70th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:18 UTC First seen by agentprime
- 31 Oct 2026, 14:18 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-h4h5-3hr4-j3g2
- OSV: GHSA-h4h5-3hr4-j3g2
- github.com/protocolbuffers/protobuf/security/advisories/GHSA-h4h5-3hr4-j3g2
- nvd.nist.gov/vuln/detail/CVE-2022-3171
- bugs.chromium.org/p/oss-fuzz/issues/detail?id=48771
- github.com/protocolbuffers/protobuf
- github.com/protocolbuffers/protobuf/releases/tag/v21.7
- github.com/protocolbuffers/protobuf/releases/tag/v3.16.3
- github.com/protocolbuffers/protobuf/releases/tag/v3.19.6
- github.com/protocolbuffers/protobuf/releases/tag/v3.20.3
- github.com/rubysec/ruby-advisory-db/blob/master/gems/google-protobuf/CVE-2022-3171.yml
- lists.fedoraproject.org/archives/list/[email protected]/message/CBAUKJQL6O4TIWYBENORSY5P43TVB4M3
- lists.fedoraproject.org/archives/list/[email protected]/message/MPCGUT3T5L6C3IDWUPSUO22QDCGQKTOP
- security.gentoo.org/glsa/202301-09