Advisory record · GHSA-h4gh-qq45-vh27

pyca/cryptography has a vulnerable OpenSSL included in cryptography wheels

No CVSS score

Published by the GitHub Advisory Database at 3 Sept 2024, 21:59 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
cryptographyPyPI>=37.0.0, <43.0.143.0.1
Identifiers
GHSA-h4gh-qq45-vh27
Weakness (CWE)
CWE-1395
Published
3 Sept 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Versions 37.0.0 through 43.0.0 of the cryptography package (PyPI wheels) bundle a statically linked copy of OpenSSL that is affected by a security issue, and the source gives few further details beyond a link to OpenSSL's advisory. Users installing cryptography wheels should upgrade to cryptography 43.0.1, which fixes the issue. Those building from the source distribution must upgrade their own OpenSSL instead.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

No source has published a CVSS score for this record yet.

  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:35 UTC First seen by agentprime
  2. 31 Oct 2026, 14:35 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.