Advisory record · GHSA-h42j-9hcc-3cwc

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.83.0 until 2.131.0, the KServeV2OcrModel class defined in docli...

CVSS 2.2 LowEPSS 0.0022 · 13th percentile

Published by the GitHub Advisory Database at 5 Oct 2026, 22:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
doclingPyPI>=2.83.0, <2.131.02.131.0
Identifiers
GHSA-h42j-9hcc-3cwc · CVE-2026-105746 · PYSEC-2026-4193
Weakness (CWE)
CWE-668 · CWE-693
Published
5 Oct 2026
Updated
8 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Docling versions 2.83.0 up to 2.131.0 send page images to a remote OCR endpoint even when the caller has set enable_remote_services to false, because the KServe V2 OCR model does not check that setting and the pipeline does not pass it through. An attacker would need no access to the system; the risk is that document images are sent to remote OCR services in setups meant to keep processing remote-free, and the endpoint is set by the caller, not the attacker. Upgrade to Docling 2.131.0 or later.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
2.2 Low 3.1 CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0022, the 13th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:08 UTC First seen by agentprime
  2. 31 Oct 2026, 14:08 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.