Advisory record · GHSA-h3x4-894j-xpx5

Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability

CVSS 9.1 CriticalCriticalEPSS 0.0064 · 51st percentile

Critical, because:

  • CVSS score 9.1: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 26 Aug 2026, 00:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.apache.tomcat:tomcatMaven>=11.0.0-M1, <11.0.25 || >=10.1.0-M1, <10.1.58 || >=9.0.0-M1, <9.0.121 || >=8.5.0, <=8.5.100 || >=7.0.0, <=7.0.10911.0.25, 10.1.58, 9.0.121
org.apache.tomcat:tomcat-catalinaMaven>=11.0.0-M1, <11.0.25 || >=10.1.0-M1, <10.1.58 || >=9.0.0-M1, <9.0.121 || >=8.5.0, <=8.5.100 || >=7.0.0, <=7.0.10911.0.25, 10.1.58, 9.0.121
org.apache.tomcat.embed:tomcat-embed-coreMaven>=11.0.0-M1, <11.0.25 || >=10.1.0-M1, <10.1.58 || >=9.0.0-M1, <9.0.121 || >=8.5.0, <=8.5.100 || >=7.0.0, <=7.0.10911.0.25, 10.1.58, 9.0.121
Identifiers
GHSA-h3x4-894j-xpx5 · BIT-tomcat-2026-68525 · CVE-2026-68525
Weakness (CWE)
CWE-863
Published
26 Aug 2026
Updated
11 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Apache Tomcat versions 11.0.0-M1 through 11.0.24, 10.1.0-M1 through 10.1.57, and 9.0.0.M1 through 9.0.120 are affected, along with EOL 8.5.x and 7.0.x releases. The packages named are org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina, and org.apache.tomcat.embed:tomcat-embed-core. A flaw in the FORM authentication process allows a security constraint limiting access to a resource's POST method to be bypassed, so GET access can be obtained; the source gives few details on the exact conditions required. Upgrade to 11.0.25, 10.1.58, or 9.0.121, which fix the issue.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.1 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.0064, the 51st percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:16 UTC First seen by agentprime
  2. 31 Oct 2026, 14:16 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.