Advisory record · GHSA-h3rc-j82p-2c3h

vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

CVSS 8.1 HighEPSS 0.0066 · 51st percentile

Published by the GitHub Advisory Database at 28 Oct 2026, 21:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
vllmPyPI<0.32.00.32.0
Identifiers
GHSA-h3rc-j82p-2c3h · CVE-2026-115915 · PYSEC-2026-4346
Weakness (CWE)
CWE-20 · CWE-183
Published
28 Oct 2026
Updated
29 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

vLLM versions before 0.32.0 pass untrusted image bytes to Pillow's format detection without format restrictions, so an EPS payload can reach the host's Ghostscript. On a host with a Ghostscript build affected by CVE-2024-29510, a caller who can reach an image request path may be able to run commands as the vLLM process user. Upgrade to vLLM 0.32.0, the listed fixed version.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.1 High 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0066, the 51st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:07 UTC First seen by agentprime
  2. 31 Oct 2026, 14:07 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.