Advisory record · GHSA-h3m5-p59h-x88p

openssl-encrypt has visible password in process list via --password CLI argument

CVSS 8.7 HighEPSS 0.0032 · 24th percentile

Published by the GitHub Advisory Database at 31 Mar 2026, 23:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
openssl-encryptPyPI<1.4.01.4.0
Identifiers
GHSA-h3m5-p59h-x88p · CVE-2026-74873 · PYSEC-2026-3753
Weakness (CWE)
CWE-214 · CWE-256
Published
31 Mar 2026
Updated
2 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

openssl-encrypt before 1.4.0 accepts passwords via the --password and --keystore-password command-line arguments, which show in the process list. Any local user on a multi-user system can read them while the command runs. Upgrade to 1.4.0 or later, and enter passwords interactively rather than on the command line.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.7 High 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N CNA (VulnCheck)
  • CISA KEV Not listed.
  • EPSS 0.0032, the 24th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:38 UTC First seen by agentprime
  2. 31 Oct 2026, 14:38 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.