Advisory record · GHSA-h2fw-rfh5-95r3

Apache Tomcat - CGI security constraint bypass

CVSS 7.3 HighEPSS 0.031 · 87th percentile

Published by the GitHub Advisory Database at 29 May 2025, 21:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.apache.tomcat:tomcat-catalinaMaven>=9.0.0.M1, <9.0.105 || >=10.1.0-M1, <10.1.41 || >=11.0.0-M1, <11.0.7 || >=8.5.0, <=8.5.1009.0.105, 10.1.41, 11.0.7
org.apache.tomcat.embed:tomcat-embed-coreMaven>=9.0.0.M1, <9.0.105 || >=10.1.0-M1, <10.1.41 || >=11.0.0-M1, <11.0.7 || >=8.5.0, <=8.5.1009.0.105, 10.1.41, 11.0.7
Identifiers
GHSA-h2fw-rfh5-95r3 · BIT-tomcat-2025-46701 · CVE-2025-46701
Weakness (CWE)
CWE-178
Published
29 May 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Apache Tomcat's CGI servlet is affected by a case sensitivity handling flaw in versions 8.5.0 through 8.5.100, 9.0.0.M1 through 9.0.104, 10.1.0-M1 through 10.1.40, and 11.0.0-M1 through 11.0.6. An attacker may be able to bypass security constraints applied to the pathInfo of URIs mapped to the CGI servlet. Upgrade to Tomcat 11.0.7, 10.1.41, or 9.0.105, which fix the issue.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.3 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L ADP (CISA-ADP)
  • CISA KEV Not listed.
  • EPSS 0.031, the 87th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:17 UTC First seen by agentprime
  2. 31 Oct 2026, 14:17 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.