Advisory record · GHSA-gx43-fqrx-6fcw

thorsten/phpmyfaq vulnerable to business logic errors

CVSS 8.3 HighEPSS 0.0070 · 53rd percentile

Published by the GitHub Advisory Database at 5 Apr 2023, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
thorsten/phpmyfaqPackagist<3.1.123.1.12
Identifiers
GHSA-gx43-fqrx-6fcw · CVE-2023-1887 · PKSA-w163-ccsb-gq3p
Weakness (CWE)
CWE-840
Published
5 Apr 2023
Updated
30 Nov 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

phpMyFAQ (thorsten/phpmyfaq) versions before 3.1.12 have a business logic flaw that lets users with edit-only permissions add and delete categories and add FAQs, which they should not be able to do. The source does not state what access an attacker needs beyond an edit-only account. Upgrade to version 3.1.12, which fixes the issue.

Written 4 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.3 High 3.0 CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:H CNA (@huntrdev)
  • CISA KEV Not listed.
  • EPSS 0.0070, the 53rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:28 UTC First seen by agentprime
  2. 31 Oct 2026, 14:28 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.