Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The rubygems-update package is vulnerable before 2.7.6, and the org.jruby:jruby-stdlib package is vulnerable before 9.1.16.0. The source describes a flaw in RubyGems' handling of the gem specification homepage attribute, which lets a malicious gem set an invalid homepage URL. The source gives few details about the attack requirements or impact. Upgrade rubygems-update to 2.7.6 or later and jruby-stdlib to 9.1.16.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.0 | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.036, the 89th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:13 UTC First seen by agentprime
- 31 Oct 2026, 15:13 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-gv86-43rv-79m2
- OSV: GHSA-gv86-43rv-79m2
- nvd.nist.gov/vuln/detail/CVE-2018-1000077
- github.com/jruby/jruby/commit/0b06b48ab4432237ce5fc1bef47f2c6bcf7843f7
- github.com/rubygems/rubygems/commit/5971b486d4dbb2bad5d3445b3801c456eb0ce183
- github.com/rubygems/rubygems/commit/feadefc2d351dcb95d6492f5ad17ebca546eb964
- www.debian.org/security/2018/dsa-4259
- www.debian.org/security/2018/dsa-4219
- usn.ubuntu.com/3621-1
- lists.debian.org/debian-lts-announce/2019/05/msg00028.html
- lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- lists.debian.org/debian-lts-announce/2018/04/msg00023.html
- lists.debian.org/debian-lts-announce/2018/04/msg00001.html
- lists.debian.org/debian-lts-announce/2018/04/msg00000.html