Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Dex versions from 2.37.0 before 2.38.0, and development builds before 0.0.0-20240125115555-5bbdb4420254, ignore the configured TLS settings when serving HTTPS, so deprecated TLS 1.0 and TLS 1.1 and the configured cipher suites are not enforced. An attacker who can intercept network traffic to Dex could decrypt connections made over these older protocols. Upgrade to Dex 2.38.0 or to 0.0.0-20240125115555-5bbdb4420254 or later. The source gives few details on the exact conditions required for interception.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0043, the 37th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:15 UTC First seen by agentprime
- 31 Oct 2026, 14:15 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-gr79-9v6v-gc9r
- OSV: GHSA-gr79-9v6v-gc9r
- github.com/dexidp/dex/security/advisories/GHSA-gr79-9v6v-gc9r
- nvd.nist.gov/vuln/detail/CVE-2024-23656
- github.com/dexidp/dex/issues/2848
- github.com/dexidp/dex/pull/2964
- github.com/dexidp/dex/commit/5bbdb4420254ba73b9c4df4775fe7bdacf233b17
- github.com/dexidp/dex
- github.com/dexidp/dex/blob/70d7a2c7c1bb2646b1a540e49616cbc39622fb83/cmd/dex/serve.go#L425