Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Http4s Ember HTTP/2 (http4s-ember-core) versions before 0.23.37, and 1.0.0-M1 up to but not including 1.0.0-M48, are affected. An unauthenticated remote peer that can open an HTTP/2 connection can make the server or client buffer up to 16 MiB of a single frame before the frame size is checked, which can lead to memory exhaustion and denial of service. Upgrade to 0.23.37 or 1.0.0-M48. Ember's HTTP/2 support is off by default, so disabling HTTP/2 or terminating it at a proxy that enforces frame size avoids exposure.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0063, the 50th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-gq9p-f254-h286
- OSV: GHSA-gq9p-f254-h286
- github.com/http4s/http4s/security/advisories/GHSA-gq9p-f254-h286
- github.com/http4s/http4s/commit/87cf334fa3f608ef7d3eb359e71e037ba3336d29
- github.com/http4s/http4s
- github.com/http4s/http4s/releases/tag/v0.23.37
- github.com/http4s/http4s/releases/tag/v1.0.0-M48