Advisory record · GHSA-gq9c-wmrm-5hvr

HAPI FHIR: SHCParser DEFLATE infinite loop causes denial of service

CVSS 7.5 HighEPSS 0.0063 · 50th percentile

Published by the GitHub Advisory Database at 17 Sept 2026, 20:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
ca.uhn.hapi.fhir:org.hl7.fhir.r5Maven<6.9.126.9.12
ca.uhn.hapi.fhir:org.hl7.fhir.validationMaven<6.9.126.9.12
ca.uhn.hapi.fhir:org.hl7.fhir.validation.cliMaven<6.9.126.9.12
Identifiers
GHSA-gq9c-wmrm-5hvr · CVE-2026-81876
Weakness (CWE)
CWE-20 · CWE-400 · CWE-835
Published
17 Sept 2026
Updated
17 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

GHSA-gq9c-wmrm-5hvr affects the Maven packages ca.uhn.hapi.fhir:org.hl7.fhir.r5, ca.uhn.hapi.fhir:org.hl7.fhir.validation and ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli, versions before 6.9.12. A malformed Smart Health Card with a DEFLATE payload that is empty or truncated can cause the SHC parser to loop forever. An attacker who can submit SHC content for validation can tie up a worker thread indefinitely, causing denial of service. Upgrade to 6.9.12.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0063, the 50th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:16 UTC First seen by agentprime
  2. 31 Oct 2026, 14:16 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.