Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Syncope core (syncope-core-spring) versions 3.0.0 through 3.0.16, 4.0.0 through 4.0.5, and 4.1.0 are affected. An administrator with entitlements for Implementations can create a Groovy class whose static initializer runs untrusted code outside the sandbox. Upgrade to 4.0.6 or 4.1.1, which force the static initializer to run in the sandbox.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.2 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0065, the 51st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:20 UTC First seen by agentprime
- 31 Oct 2026, 14:20 UTC Confirmed by OSV