Advisory record · GHSA-gq5q-89c7-vhvx

vLLM DeepSeek-OCR image processing vulnerable to denial of service

CVSS 6.5 MediumEPSS 0.0040 · 34th percentile

Published by the GitHub Advisory Database at 28 Oct 2026, 21:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
vllmPyPI>=0.11.1, <0.32.00.32.0
Identifiers
GHSA-gq5q-89c7-vhvx · CVE-2026-115914
Weakness (CWE)
CWE-617
Published
28 Oct 2026
Updated
28 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

vLLM versions from 0.11.1 before 0.32.0 that serve DeepSeek-OCR family models (DeepSeek-OCR, DeepSeek-OCR-2, or Unlimited-OCR) can be crashed by one unauthenticated chat request containing an image with a specific pixel distribution, under default configuration. The crash takes down the serving process, and the deployment stays down until it is manually restarted. Upgrade vLLM to 0.32.0 or later.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.5 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0040, the 34th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:07 UTC First seen by agentprime
  2. 31 Oct 2026, 14:07 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.