Advisory record · GHSA-ggpf-24jw-3fcw

CVE-2025-24357 Malicious model remote code execution fix bypass with PyTorch < 2.6.0

CVSS 9.8 CriticalCritical

Critical, because:

  • CVSS score 9.8: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 23 Apr 2025, 02:26 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
vllmPyPI<0.8.00.8.0
Identifiers
GHSA-ggpf-24jw-3fcw
Weakness (CWE)
CWE-1395
Published
23 Apr 2025
Updated
7 Aug 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

vllm versions before 0.8.0 can run code on the host when a malicious model is loaded, because the earlier weights_only=True fix for torch.load() did not hold on PyTorch before 2.6.0. An attacker would need a user to load a model they supply. Upgrade vllm to 0.8.0 and use PyTorch 2.6.0 or later.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.8 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:40 UTC First seen by agentprime
  2. 31 Oct 2026, 14:40 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.