Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Versions of openam-auth-webauthn before 16.1.2 in the Maven package org.openidentityplatform.openam:openam-auth-webauthn are affected. An unauthenticated remote attacker can send a crafted serialized object that runs arbitrary code during deserialization, provided a suitable gadget class is on the classpath. Upgrade to version 16.1.2, which fixes the issue.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.2 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0086, the 58th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-gf8h-gq53-288j
- OSV: GHSA-gf8h-gq53-288j
- github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-gf8h-gq53-288j
- github.com/OpenIdentityPlatform/OpenAM/commit/9dd0fbe07f70f118cf45042d3a9ffb32f3c21e08
- github.com/OpenIdentityPlatform/OpenAM
- github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.2