Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Tomcat versions 11.0.0-M1 through 11.0.24, 10.1.0-M1 through 10.1.57, 9.0.0.M1 through 9.0.120, 8.5.0 through 8.5.100, and 7.0.0 through 7.0.109 are affected, along with the tomcat, tomcat-catalina and tomcat-embed-core Maven packages. When a constraint on a longer path is configured before a more restrictive constraint on a shorter sub-path, the source says the security constraint can be bypassed. The source does not describe the attacker's required access level. Upgrade to 11.0.25, 10.1.58, or 9.0.121, which fix the issue; no fix is listed for 8.5.x or 7.0.x.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.1 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0065, the 51st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-gcx9-497g-6cp6
- OSV: GHSA-gcx9-497g-6cp6
- nvd.nist.gov/vuln/detail/CVE-2026-65182
- github.com/apache/tomcat/commit/8bafd79a3b54684e80e9cb1bafd4746aede7d3f5
- github.com/apache/tomcat/commit/b2c56ec8f20c66773a1a813034ffcdb60841f1cf
- github.com/apache/tomcat/commit/b79752d2a8578d94743e2a95c50af297f780c0df
- lists.apache.org/thread/joosxvzc9b49ttj8lj0jw9mqt0ml767m
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html
- www.openwall.com/lists/oss-security/2026/08/26/1