Advisory record · GHSA-gccq-h3xj-jgvf

Pixelfed doesn't check OAuth Scopes in API routes, giving elevated permissions

CVSS 9.9 CriticalCriticalEPSS 0.0068 · 52nd percentile

Critical, because:

  • CVSS score 9.9: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 12 Feb 2024, 15:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
pixelfed/pixelfedPackagist>=0.10.4, <0.11.110.11.11
Identifiers
GHSA-gccq-h3xj-jgvf · CVE-2024-25108 · PKSA-bgxg-jhn7-yhxd
Weakness (CWE)
CWE-280 · CWE-285 · CWE-863
Published
12 Feb 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Pixelfed versions from 0.10.4 up to 0.11.11 (fixed in 0.11.11) do not check that an OAuth application's granted scopes cover the API endpoint being called, so a token issued for read access can perform write or administrative actions. An attacker who holds a read-scoped access token, whether obtained through a third-party application or a personal token, can reach higher-privilege functions, including administrative and moderator functions, with no further user action. Upgrade Pixelfed to 0.11.11 or later.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.9 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0068, the 52nd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:04 UTC First seen by agentprime
  2. 31 Oct 2026, 14:04 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.