Advisory record · GHSA-g9m2-c2x5-fr2v

Moodle does not revoke role capabilities correctly

CVSS 4.2 MediumEPSS 0.0071 · 53rd percentile

Published by the GitHub Advisory Database at 24 May 2022, 17:05 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
moodle/moodlePackagist>=3.7.0, <3.7.3 || >=3.6.0, <3.6.7 || >=3.5.0, <3.5.93.7.3, 3.6.7, 3.5.9
Identifiers
GHSA-g9m2-c2x5-fr2v · CVE-2019-14879 · PKSA-tsyk-q1km-44v1
Weakness (CWE)
CWE-264 · CWE-273
Published
24 May 2022
Updated
16 Feb 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Moodle versions 3.5.0 before 3.5.9, 3.6.0 before 3.6.7, and 3.7.0 before 3.7.3 do not revoke role capabilities correctly. When a cohort role assignment was removed, the associated capabilities were not always revoked, so a user could keep permissions they should have lost. The source gives few details on who can exploit this or how. Upgrade to Moodle 3.5.9, 3.6.7, 3.7.3, or later.

Written 4 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
4.2 Medium 3.0 CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N CNA (redhat)
  • CISA KEV Not listed.
  • EPSS 0.0071, the 53rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:31 UTC First seen by agentprime
  2. 31 Oct 2026, 14:31 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.