Advisory record · GHSA-g5rr-p69h-7v3g

Insufficient type validation in pocketmine/pocketmine-mp

CVSS 7.1 HighEPSS 0.0053 · 44th percentile

Published by the GitHub Advisory Database at 22 Apr 2022, 20:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
pocketmine/pocketmine-mpPackagist<4.2.94.2.9
Identifiers
GHSA-g5rr-p69h-7v3g · CVE-2022-51012 · PKSA-8sgq-z2gv-62hz
Weakness (CWE)
CWE-20 · CWE-1287
Published
22 Apr 2022
Updated
8 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The pocketmine/pocketmine-mp package for PHP is vulnerable in versions before 4.2.9. When a player performs an inventory action, the server deserializes item NBT sent by the client, and malformed data such as an incorrect list tag type for a block-related tag can crash the server. The source does not state what access an attacker needs beyond connecting as a client. Upgrade to version 4.2.9, which includes the fix; the workaround described in the source is non-trivial.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.1 High 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N CNA (VulnCheck)
  • CISA KEV Not listed.
  • EPSS 0.0053, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:06 UTC First seen by agentprime
  2. 31 Oct 2026, 14:06 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.