Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Hashicorp Vault versions 1.2.0 up to 1.18.1 and OpenBao versions before 2.0.3 are vulnerable when they use the Integrated Storage backend. An attacker who can send a large volume of requests to the Raft cluster join API endpoint can exhaust system memory, potentially crashing the server. Upgrade Vault to 1.18.1 or OpenBao to 2.0.3; the source also lists fixed Vault Enterprise releases 1.17.8 and 1.16.12.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (HashiCorp) |
- CISA KEV Not listed.
- EPSS 0.0048, the 41st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:15 UTC First seen by agentprime
- 31 Oct 2026, 14:15 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-g233-2p4r-3q7v
- OSV: GHSA-g233-2p4r-3q7v
- nvd.nist.gov/vuln/detail/CVE-2024-8185
- github.com/hashicorp/vault/commit/195dfca433028887973f5bd82d173d91fe9dab4a
- discuss.hashicorp.com/t/hcsec-2024-26-vault-vulnerable-to-denial-of-service-through-memory-exhaustion-when-processing-raft-cluster-join-requests/71047
- github.com/hashicorp/vault
- openbao.org/docs/release-notes/2-0-0/#203