Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The vLLM package before 0.32.0 is affected when the OffloadingConnector uses a P2P secondary tier. An attacker with network access to the inference endpoint and a normal API key (when API key authentication is enabled) can send many requests naming unique peer addresses that never connect, exhausting ZeroMQ sockets until the engine process and API server terminate, which causes denial of service. Upgrade to vLLM 0.32.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0043, the 37th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-frvg-qw88-hww9
- OSV: GHSA-frvg-qw88-hww9
- github.com/vllm-project/vllm/security/advisories/GHSA-frvg-qw88-hww9
- nvd.nist.gov/vuln/detail/CVE-2026-94624
- github.com/vllm-project/vllm/pull/51504
- github.com/vllm-project/vllm/commit/93d2cab35e8ae66bbaa1dea1c077986d5a79eb80
- github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-4006.yaml
- github.com/vllm-project/vllm
- github.com/vllm-project/vllm/blob/v0.29.0/vllm/v1/kv_offload/tiering/p2p/control/zmq.py#L240-L260
- github.com/vllm-project/vllm/blob/v0.29.0/vllm/v1/kv_offload/tiering/p2p/manager.py#L667-L677
- github.com/vllm-project/vllm/releases/tag/v0.32.0
- www.vulncheck.com/advisories/vllm-through-0.29.0-denial-of-service-via-unbounded-p2p-kv-offloading-sessions