Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The kaml library (Maven com.charleskorn.kaml:kaml) versions before 0.35.3 are affected. An attacker who can supply arbitrary YAML input to an application that uses polymorphic serialization with the default tagged style can cause parsing to loop endlessly, leading to resource starvation and denial of service. Upgrade to kaml 0.35.3 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.017, the 76th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:20 UTC First seen by agentprime
- 31 Oct 2026, 14:20 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-fmm9-3gv8-58f4
- OSV: GHSA-fmm9-3gv8-58f4
- github.com/charleskorn/kaml/security/advisories/GHSA-fmm9-3gv8-58f4
- nvd.nist.gov/vuln/detail/CVE-2021-39194
- github.com/charleskorn/kaml/issues/179
- github.com/charleskorn/kaml/commit/e18785d043fc6324c81e968aae9764b4b060bc6a
- github.com/charleskorn/kaml