Advisory record · GHSA-fmjh-f678-cv3x

github.com/nyaruka/phonenumbers Vulnerable to Improper Validation of Syntactic Correctness of Input

CVSS 6.9 MediumEPSS 0.0046 · 39th percentile

Published by the GitHub Advisory Database at 27 Sept 2025, 06:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/nyaruka/phonenumbersGo<1.2.21.2.2
Identifiers
GHSA-fmjh-f678-cv3x · CVE-2025-10954 · GO-2025-3987
Weakness (CWE)
CWE-1286
Published
27 Sept 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Versions of github.com/nyaruka/phonenumbers before 1.2.2 are vulnerable to improper input validation in the Parse() function. An attacker who can supply crafted phone number input can cause a panic (a slice bounds out of range runtime error). Upgrade to version 1.2.2 or later.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.9 Medium 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P CNA (snyk)
  • CISA KEV Not listed.
  • EPSS 0.0046, the 39th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:14 UTC First seen by agentprime
  2. 31 Oct 2026, 14:14 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.