Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GeoServer (packages gs-web-app and gs-wms) versions 2.26.0 up to 2.26.2 and versions before 2.25.6 are affected. The WMS GetMap operation accepts XML input without adequate restriction on external entities, so an unauthenticated attacker can send a crafted request to read arbitrary files from the server, perform server-side request forgery against internal systems, or cause denial of service. Upgrade to 2.25.6 or 2.26.3 or later; the source lists 2.26.2 as a fixed version for these packages but its resolution names 2.26.3 and 2.27.0.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L | CNA (GitHub_M) |
- CISA KEV Listed since 11 Dec 2025: known to be exploited.
- EPSS 0.61, the 99th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:09 UTC First seen by agentprime
- 31 Oct 2026, 15:09 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-fjf5-xgmq-5525
- OSV: GHSA-fjf5-xgmq-5525
- github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525
- nvd.nist.gov/vuln/detail/CVE-2025-58360
- github.com/geoserver/geoserver
- osgeo-org.atlassian.net/browse/GEOS-11682
- www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-58360