Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Affected: praisonai (PyPI) versions before 4.6.78 are vulnerable. The InjectionDefense class uses a default block threshold of CRITICAL, so inputs that trigger only one detection check, including instruction override and financial manipulation, are logged as HIGH but not blocked and are forwarded to the LLM. An attacker who can send prompts to an application using default settings can attempt prompt injection, such as system prompt extraction or unauthorized tool use. Upgrade to 4.6.78 or later. Operators can set block_threshold to HIGH as a workaround.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0034, the 27th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV