Advisory record · GHSA-fj7x-q9j7-g6q6

Black vulnerable to Regular Expression Denial of Service (ReDoS)

CVSS 5.3 MediumEPSS 0.0098 · 62nd percentile

Published by the GitHub Advisory Database at 19 Mar 2024, 06:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
blackPyPI<24.3.024.3.0
Identifiers
GHSA-fj7x-q9j7-g6q6 · CVE-2024-21503 · PYSEC-2024-48
Weakness (CWE)
CWE-75 · CWE-1333
Published
19 Mar 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Black versions before 24.3.0 are vulnerable to a Regular Expression Denial of Service (ReDoS) through the lines_with_leading_tabs_expanded function. An attacker who can supply input to Black, such as by running it on untrusted code, can cause a denial of service. Upgrade to black 24.3.0 or later; if upgrading is not possible, avoid running Black on untrusted input.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.3 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P CNA (snyk)
  • CISA KEV Not listed.
  • EPSS 0.0098, the 62nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:35 UTC First seen by agentprime
  2. 31 Oct 2026, 14:35 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.