Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
kin-openapi, Go module github.com/getkin/kin-openapi, versions before 0.145.0, is vulnerable: a request with a non-standard or differently cased HTTP method (such as PROPFIND or lowercase get) sent to an existing static path behind the openapi3filter ValidationHandler causes a panic. No authentication is needed, so a remote attacker can trigger repeated per-connection panics and log growth, causing denial of service. Upgrade to version 0.145.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0052, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:12 UTC First seen by agentprime
- 31 Oct 2026, 14:12 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-fh4f-47mf-f2gj
- OSV: GHSA-fh4f-47mf-f2gj
- github.com/getkin/kin-openapi/security/advisories/GHSA-fh4f-47mf-f2gj
- nvd.nist.gov/vuln/detail/CVE-2026-100347
- github.com/getkin/kin-openapi/commit/f1a5b523b82868d2d9be2e116b4e942892be72c3
- github.com/getkin/kin-openapi
- github.com/getkin/kin-openapi/releases/tag/v0.145.0