Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
YOURLS versions 1.10.4 and earlier (affected below 1.10.5) contain an unauthenticated path traversal flaw that lets an attacker include and execute arbitrary PHP files on the server. An attacker needs no credentials, but must first place a PHP file somewhere on the server through another means, such as a separate upload feature or code injection; they can then cause YOURLS to run it. The fix is to upgrade to YOURLS 1.10.5.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0047, the 40th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:53 UTC First seen by agentprime
- 31 Oct 2026, 13:53 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-f8ff-652m-j5rx
- OSV: GHSA-f8ff-652m-j5rx
- github.com/YOURLS/YOURLS/security/advisories/GHSA-f8ff-652m-j5rx
- nvd.nist.gov/vuln/detail/CVE-2026-62858
- github.com/YOURLS/YOURLS/pull/4142
- github.com/YOURLS/YOURLS/commit/4e85972160a96e03a419a442d5bd8f21f2f02ddb
- github.com/YOURLS/YOURLS
- github.com/YOURLS/YOURLS/releases/tag/1.10.5