Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The npm package sharp, versions before 0.35.0, is affected by several vulnerabilities inherited from the upstream libvips dependency, two of which are rated High under CVSSv4. An attacker who can get sharp to process untrusted images could be affected, and the advisory does not describe the specific impact of each flaw beyond this. Upgrade sharp to 0.35.0 or later; the source names 0.35.3, which bundles libvips 8.18.3. Users with a globally installed libvips should move to libvips 8.18.3, and the source also describes a workaround that disables decoding of GIF, TIFF and VIPS images.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.4 | High | 4.0 | CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0011, the 1st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-f88m-g3jw-g9cj
- OSV: GHSA-f88m-g3jw-g9cj
- github.com/libvips/libvips/security/advisories/GHSA-2fcj-gj27-279x
- github.com/libvips/libvips/security/advisories/GHSA-523x-vhfw-6r76
- github.com/libvips/libvips/security/advisories/GHSA-jmwm-wc68-mhwm
- github.com/libvips/libvips/security/advisories/GHSA-r98w-4fp7-m9c7
- github.com/lovell/sharp/security/advisories/GHSA-f88m-g3jw-g9cj
- github.com/lovell/sharp