Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Next.js versions 16.0.0 up to but not including 16.3.8 are affected in App Router applications built with webpack. Metadata image routes such as opengraph-image and twitter-image ignore the dynamicParams route segment option, so an attacker can request metadata image URLs for dynamic segments that were deliberately excluded from generateStaticParams(). Upgrade the next package to version 16.3.8 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.3 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0017, the 6th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-f87g-xv8r-7p7x
- OSV: GHSA-f87g-xv8r-7p7x
- github.com/vercel/next.js/security/advisories/GHSA-f87g-xv8r-7p7x
- nvd.nist.gov/vuln/detail/CVE-2026-94485
- github.com/vercel/next.js/commit/2d9f50a409312696145b82b3157aadb6b1fef476
- github.com/vercel/next.js
- github.com/vercel/next.js/releases/tag/v16.3.8