Advisory record · GHSA-f7w7-6pjc-wwm6

Apache Tomcat affected by vulnerability in TLS and SSL protocol

CVSS 9.8 CriticalCriticalEPSS 0.87 · 99th percentile

Critical, because:

  • CVSS score 9.8: 9.0 or more.
  • CVSS score 9.8 (7.0 or more) and EPSS 0.87 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical

Published by the GitHub Advisory Database at 2 May 2022, 03:46 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.apache.tomcat:tomcatMaven>=7.0.0, <7.0.10 || >=6.0.0, <6.0.32 || >=5.0.0, <5.5.337.0.10, 6.0.32, 5.5.33
Identifiers
GHSA-f7w7-6pjc-wwm6 · CVE-2009-3555
Weakness (CWE)
CWE-295 · CWE-300
Published
2 May 2022
Updated
9 Jun 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Apache Tomcat versions 5.0.0 through 5.5.32, 6.0.0 through 6.0.31, and 7.0.0 through 7.0.9 are affected by a TLS/SSL renegotiation flaw. A man-in-the-middle attacker on the network can insert data into HTTPS sessions by sending an unauthenticated request that the server processes in a post-renegotiation context. Upgrade to Tomcat 7.0.10, 6.0.32, or 5.5.33 or later.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.8 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.87, the 99th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:20 UTC First seen by agentprime
  2. 31 Oct 2026, 14:20 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.