Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The @grpc/grpc-js package for npm is vulnerable in versions below 1.13.6 and from 1.14.0 up to but not including 1.14.5. When an application's method handler crashes, the server may include the error message in the status message sent to the client, which can expose sensitive data contained in that message. Upgrade to 1.13.6 or 1.14.5, or add a top-level error handler in method handlers that strips sensitive details from errors.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 3.7 | Low | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0025, the 16th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:34 UTC First seen by agentprime
- 31 Oct 2026, 13:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-f596-whhp-79r4
- OSV: GHSA-f596-whhp-79r4
- github.com/grpc/grpc-node/security/advisories/GHSA-f596-whhp-79r4
- nvd.nist.gov/vuln/detail/CVE-2026-101915
- github.com/grpc/grpc-node/commit/350de32860428cc62473a00bee4035360690ffea
- github.com/grpc/grpc-node/commit/7c5c5181159c6ddd292805881ef2cdec29bb475f
- github.com/grpc/grpc-node/commit/e8329b122ca99ba10877e990c2f6edd40224fd0d
- github.com/grpc/grpc-node
- github.com/grpc/grpc-node/releases/tag/@grpc/grpc-js%401.13.6
- github.com/grpc/grpc-node/releases/tag/@grpc/grpc-js%401.14.5