Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Tomcat versions 11.0.20 through 11.0.24, 10.1.53 through 10.1.57, and 9.0.115 through 9.0.120 are affected, as are the tomcat-coyote and tomcat-embed-core Maven packages in those ranges. The source gives few details on how the bypass is triggered or what an attacker can do after it. Users should upgrade to Tomcat 11.0.25, 10.1.59, or 9.0.121, which fix the issue.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0075, the 55th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-f525-44xv-f2qj
- OSV: GHSA-f525-44xv-f2qj
- nvd.nist.gov/vuln/detail/CVE-2026-65637
- github.com/apache/tomcat/commit/40012414df828a56126f76a7339669c7c919aae7
- github.com/apache/tomcat/commit/8639b20f045c88f356b887204f52e897399f0de7
- github.com/apache/tomcat/commit/b823e88da077f5fa973e34d72359bded9f621e3c
- github.com/apache/tomcat
- github.com/apache/tomcat/releases/tag/10.1.58
- github.com/apache/tomcat/releases/tag/11.0.25
- github.com/apache/tomcat/releases/tag/9.0.121
- lists.apache.org/thread/djog953z1ohsyt25bdvhfzbmsy22vgcj
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html