Advisory record · GHSA-f3r2-88mq-9v4g

Auth0 Symfony SDK has Improper Audience Validation via Auth0-PHP SDK

CVSS 6.8 Medium

Published by the GitHub Advisory Database at 17 Dec 2025, 20:56 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
auth0/symfonyPackagist>=5.0.0, <5.6.05.6.0
Identifiers
GHSA-f3r2-88mq-9v4g · PKSA-3pss-my3n-f2df
Weakness (CWE)
CWE-345 · CWE-863 · CWE-1395
Published
17 Dec 2025
Updated
4 Feb 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Auth0 Symfony SDK versions 5.0.0 through 5.5.0 are affected when used with Auth0-PHP SDK versions 8.0.0 through 8.17.0. Because audience validation is performed improperly, applications may accept ID tokens as access tokens. The source does not describe what an attacker must do beyond presenting such a token. Upgrade auth0/symfony to version 5.6.0 or greater.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.8 Medium 3.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:26 UTC First seen by agentprime
  2. 31 Oct 2026, 14:26 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.